TESTING

Incident Report for BetterHealthcare Status Page

Resolved

This incident has been resolved.
Posted Dec 09, 2020 - 20:16 EST

Update

We are continuing to investigate this issue.
Posted Dec 09, 2020 - 16:49 EST

Update

Our data processing infrastructure is running behind which is causing inaccuracies in the reporting tools. No data has been lost and the system should be caught up shortly.
Posted Dec 09, 2020 - 16:49 EST

Investigating

TESTING
Posted Dec 09, 2020 - 16:48 EST
This incident affected: API (RESTful API).