Intermittent Connectivity Issues

Incident Report for BetterHealthcare Status Page

Resolved

The incident is resolved.
Posted Oct 17, 2022 - 13:21 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 17, 2022 - 13:08 EDT

Investigating

Users may experience intermittent connectivity issues when accessing the location and company detail pages on https://listings.betterhealthcare.co.
Posted Oct 17, 2022 - 12:20 EDT
This incident affected: Scheduling.