General Issues

Incident Report for BetterHealthcare Status Page

Resolved

All services are restored.
Posted Dec 08, 2021 - 09:59 EST

Update

Most services are back online. We are continuing to monitor the situation.
Posted Dec 07, 2021 - 22:02 EST

Monitoring

AWS executed a mitigation which is showing significant recovery in our region. We are monitoring.
Posted Dec 07, 2021 - 17:28 EST

Update

AWS has provided its customers with more detailed information, but we are still waiting on a fix.
Posted Dec 07, 2021 - 16:46 EST

Identified

The issue with AWS has been identified. AWS is working towards a resolution.
Posted Dec 07, 2021 - 12:58 EST

Investigating

Amazon Web Services is having general service issues which may affect application connectivity. We will provide an update as soon as we have one.
Posted Dec 07, 2021 - 12:05 EST
This incident affected: Login and Single Sign-On, Email and SMS, Scheduling, Telehealth, and Integrations.