Intermittent connectivity issues that might affect the ability to log in.

Incident Report for BetterHealthcare Status Page

Resolved

This incident has been resolved.
Posted Jan 05, 2021 - 10:00 EST

Update

Our team has implemented a fix while we continue to address the underlying issue. If you continue to encounter issues, please refresh your browser.
Posted Jan 04, 2021 - 17:20 EST

Update

We are continuing to monitor for any further issues.
Posted Jan 04, 2021 - 14:11 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 04, 2021 - 13:10 EST

Update

We are continuing to work on a fix for this issue.
Posted Jan 04, 2021 - 11:40 EST

Update

We are still seeing intermittent connectivity and are actively investigating the issue.
Posted Jan 04, 2021 - 11:35 EST

Update

We are continuing to work on a fix for this issue.
Posted Jan 04, 2021 - 10:01 EST

Identified

We are experiencing intermittent connectivity issues related to our API. We will update you as we find out more.
Posted Jan 04, 2021 - 10:01 EST
This incident affected: Login and Single Sign-On.