Degradation of Service

Incident Report for BetterHealthcare Status Page

Resolved

This incident has been resolved.
Posted Oct 23, 2020 - 15:02 EDT

Monitoring

A fix has been deployed and we are monitoring.
Posted Oct 23, 2020 - 14:44 EDT

Investigating

An issue has been identified on production that impacts a subset of our customers.
Posted Oct 23, 2020 - 14:37 EDT
This incident affected: Telehealth.