Login Issues

Incident Report for BetterHealthcare Status Page

Resolved

This incident has been resolved.
Posted Nov 25, 2020 - 18:31 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 25, 2020 - 17:38 EST

Update

NOTE: This does not affect pre-existing Telehealth appointments. As soon as AWS resolves this issue, users will be able to login.
Posted Nov 25, 2020 - 10:56 EST

Identified

We’re currently experiencing a service outage that is affecting the ability to log-in to our system due to an outage with AWS (Amazon Web Services). This outage is affecting millions of users across the United States. Our team is currently working to restore the service. We apologize for any inconvenience that this may cause. This is an AWS Issue. Please see here as it relates to AWS Cognito:

https://status.aws.amazon.com/
Posted Nov 25, 2020 - 10:35 EST

Investigating

We are currently investigating this issue. It appears to be AWS-related
Posted Nov 25, 2020 - 10:34 EST
This incident affected: Login and Single Sign-On.