SFTP Connectivity

Incident Report for BetterHealthcare Status Page

Resolved

This incident has been resolved.
Posted Nov 10, 2020 - 21:38 EST

Monitoring

A fix has been implemented, we are monitoring the situation.
Posted Nov 10, 2020 - 11:36 EST

Identified

We have identified the issue and are waiting on a fix. Please note that this does not affect the majority of our customers.
Posted Nov 09, 2020 - 17:43 EST
This incident affected: Integrations.